wordpress错误提示“ disabled for security reasons in *** wp-includes/l10n.php on line 1055”解决方法

新客网 XKER.COM 时间:2017-07-17 17:07:10来源:新客网原创  评论:

linux下wordpress程序,安装/编辑主题时会出现如下错误(你的错误可能不完全一致但是类似):

notice: /home/wwwroot/che163.top/wordpress/wp-content/themes is not readable in /home/wwwroot/che163.top/wordpress/wp-includes/theme.php on line 447 Warning: scandir() has been disabled for security reasons in /home/wwwroot/che163.top/wordpress/wp-includes/l10n.php on line 764

经过查找资料,发现是因为默认情况下php中scandir被禁用了。

解决方法:

找到php.ini文件,php.ini 的位置:/usr/local/php/etc/php.ini,找到如下代码:

  1. disable_functions = scandir,passthru,exec,system,chroot,chgrp,chown,shell_exec,proc_open,proc_get_status,ini_alter,ini_alter,ini_restore,dl,pfsockopen,openlog,syslog,readlink,symlink,popepassthru,stream_socket_server,fsocket,fsockopen 

去掉scandir后保存。

并重新启动php-fpm即可,命令:/etc/init.d/php-fpm restart

重启完成后返回刷新页面,解决!

本文来源:新客网原创

如果您喜欢本文请分享给您的好友,谢谢!如想浏览更多更好的建站程序内容,请登录:http://www.xker.com/edu/website/6/index.html